大智慧公式网收录大智慧公式,大智慧公式源码.域名http://www.yaoyaoyuan.cn
所在的位置: 大智慧公式网 > 通达信公式 > 正文

公式源码:通达信资金动能副图指标公式(副图)

2013-12-10 00:00:00 通达信公式教程
摘要: 买好股公式文章同花顺四档观望公式源码,介绍同花顺,公式,源码炒股技巧,让您在股市里买到好股票。本指标从四个维度来研判股票的走势。 指标用法:红灯停、绿灯行、黄灯等待。 使用时配合其他分析手段效果更佳,指标已经公布源码,大家可以下载优化。 C15:=C;{指标公式网选编}A15:=MAX(MA(C15,4),MA(C15,8));B15:=...阻力,突破,操作,警戒,股价通达信资金动能副图指标公式副图 动能 公式 指标 资金VOLUME:VOL/2.9,VOLSTICK;{通达信指标公式网选编}N:=5;JJ:=(HIGH+LOW+CLOSE)/3;QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));QJ2:=IF(CAPITAL=0,QJ0*(MIN(

VOLUME:VOL/2.9,VOLSTICK;
{通达信指标公式网选编}
N:=5;
JJ:=(HIGH+LOW+CLOSE)/3;
QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));
QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));
DDX:10000*IF(((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,1000000,10000)>0,
((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,1000000,10000),
-((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,1000000,10000)),COLORRED,NODRAW;
AABB:=((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,1000000,10000);
STICKLINE(((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,1000000,10000)>0,0,DDX,1.5,0),COLORLIRED;
STICKLINE((AABB*10000/VOLUME)>0.6,0,DDX,1.5,0),COLORRED;
STICKLINE(((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,1000000,10000)<0,0,DDX,1.5,0),COLOR00CC00;
STICKLINE(((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,1000000,10000)<0,0,DDX,1,0),COLOR00EE00;
三十天红:COUNT(AABB>=0,30),COLORRED,NODRAW;
六十天红:COUNT(AABB>=0,60),COLORRED,NODRAW;
V5:MA(VOLUME,5),COLORWHITE;
V35:MA(VOLUME,35),COLORYELLOW;
V135:MA(VOLUME,135),COLORFF00FF;
{}
TTT:=CONST(HHV(VOLUME,60));
DRAWTEXT(CURRBARSCOUNT=40,TTT,'DDX大单进红色'),COLORRED;
DRAWTEXT(CURRBARSCOUNT=30,TTT,'DDX大单出绿色'),COLORGREEN;
低量:DRAWTEXT(VOL<LLV(REF(VOL,1),45) AND VOL>LLV(REF(VOL,1),135),V35,'低'),COLORYELLOW;
地量:DRAWTEXT(VOL<LLV(REF(VOL,1),135),V5,'地'),COLORGREEN;
{}
D:= EMA((CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,20);
J:= EMA((CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,5) ;
BIAS1W :=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIAS2W :=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
BIAS3W :=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
MM:=(BIAS1W+2*BIAS2W+3*BIAS3W)/6;
MN:=MA(MM,3);
VAR1:=(HHV(HIGH,24)-CLOSE)/(HHV(HIGH,24)-LLV(LOW,24))*100;
VAR2:=(CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100;
VAR3:=(2*CLOSE+HIGH+LOW)/4;
VAR4:=LLV(LOW,26);
VAR5:=HHV(HIGH,34);
VAR6:=EMA((VAR3-VAR4)/(VAR5-VAR4)*100,16);
VAR7:=SMA((SMA(VAR2,3,1)+3),3,1),LINETHICK3;
VAR8:=EMA(VAR6,7);
VAR9:=SMA(VAR1,3,1);
VAR10:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR11:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR12:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;
VAR13:=(VAR10+VAR11+VAR12)/3;
VAR14:=IF(VAR13<=-20,10,0);
VAR15:=HHV(VAR14,10);
VAR24:=LLV(LOW,36);
VAR25:=HHV(HIGH,30);
VAR26:=EMA((CLOSE-VAR24)/(VAR25-VAR24)*4,4)*25;
底背离: IF((VAR26<10),V135*1.1,0), COLORRED,LINETHICK2;
顶背离: IF((VAR26>90),V135,0), COLORGREEN,LINETHICK2;
地量1:IF(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),V5,0),COLORYELLOW,LINETHICK2;
{}
股价趋势:= 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
底部警戒:=10,COLORRED,LINETHICK2;
底1:=CROSS(股价趋势,底部警戒);
A1:=(2*CLOSE+HIGH+LOW)/4;
A2:=LLV(LOW,27);
A3:=HHV(HIGH,27);
A4:=EMA((A1-A2)/(A3-A2)*100,13);
A5:=EMA(0.618*REF(A4,1)+0.382*A4,3);
底2:=CROSS(A4,A5) AND A4<16;
波底:=底1 AND 底2;
{牛年奔牛}
VARC2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VARC3:=SMA(SMA(VARC2,3,1),3,1)/28.57;
VARC4:=EMA(VARC3,5);
VARC5:=3*VARC3-2*VARC4;
牛:=CROSS(VARC5,VARC3) AND VARC3<2.1 AND C>O;
{突破与破位}
VARB1:=HHV(HIGH,19);
VARB2:=LLV(LOW,19);
阻力线:=EMA((CLOSE-VARB2)/(VARB1-VARB2),21)-0.5;
操作线:=EMA((CLOSE-VARB2)/(VARB1-VARB2),5)-0.5;
突破:=CROSS(操作线,阻力线) AND 阻力线<0.1;
破位:=CROSS(阻力线,操作线) AND 阻力线>0.25;
{立桩成立判断}
V2:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);
T12:=V2>=1;
T0:=BARSLAST(T12);
L1:=REF(L,T0);
H1:=REF(H,T0);
L11:=MIN(REF(L,1),L);
L10:=MIN(L11,REF(L,2));
L21:=MAX(REF(L,1),L);
L20:=MAX(L21,REF(L,2));
T111:=(REF(V2>=1,3) OR REF(V2>=1,2) OR REF(V2>=1,1)) AND
((L10>L1 AND L20>H1) OR (L11>L1 AND L21>H1) OR (L>H1));
T11:=T111 AND REF(T111,1)=0;
{彩色成交量柱线}
STICKLINE(V2>=1,0,VOLUME*0.5,1,0),COLORYELLOW;
STICKLINE(波底,0,VOLUME,1,0),COLORMAGENTA;
DRAWTEXT(波底,VOLUME*0.8,'底'),COLORWHITE;
DRAWICON(波底,VOLUME*1.1,5);
STICKLINE(牛,0,VOLUME,1,0),COLORRED;
DRAWTEXT(牛,VOLUME*1.15,'牛'),COLORWHITE;
STICKLINE(突破,0,VOLUME,1,0),COLORBLUE;
DRAWTEXT(突破,VOLUME*0.5,'突破'),COLORWHITE;
DRAWICON(突破,VOLUME*1.2,1);
STICKLINE(破位,0,VOLUME,0.5,0),COLORBROWN;
DRAWTEXT(破位,VOLUME*0.5,'破位'),COLORBLUE;
DRAWICON(破位,VOLUME*1.05,2);
{}
BNB:=EMA(IF(L<= LLV(L,30),SMA(ABS(L-REF(L,1)),30,1)/SMA(MAX(L-REF(L,1),0),30,1),0),3);
AAAA:=IF(ABS(BNB*15000)/TTT>0.6,0.01,0.6)*30000;
BGB:=SUM(TTT-BNB*AAAA,3)/3;
动态底部:STICKLINE(1,TTT,BGB,1,0),COLORYELLOW;
STICKLINE(BNB>0.2 AND BGB<REF(BGB,1),TTT,BGB,1,0),COLORBLUE;
 



  声明:本站部分内容来自合作媒体及网络,不代表本站观点。本站不对上述言论承担责任。关键字:阻力,突破,操作,警戒,股价
相关阅读:
  • >>指标公式:同花顺主力动态公式源码(同花顺)
    买好股公式文章同花顺主力动态公式源码,介绍同花顺,主力,公式,源码炒股技巧,让您在股市里买到好股票。指标用法: 绿线为短期主力运作轨迹,黄线为中期主力运作轨迹,白线为长期主力运作轨迹。主力进出指标的绿线向上突破黄线、白线且三线...
  • >>公式-通达信分时寻找涨停起爆点指标公式(分时)
    {分时寻找涨停起爆点}流通盘:=CAPITAL*100/100000000,NODRAW;资金流入:=SUM(IF(C>REF(C,1),V,0),FROMOPEN),STICK,COLORRED;资金流出:=-SUM(IF(C<REF(C,1),V,0),FROMOPEN),STICK,COLOR00FF00;资金出入:=资金流入+资金流出,COLORSTICK;...
  • >>指标公式:通达信买卖高手指标公式(公式)
    买好股公式文章通达信买卖高手指标公式,介绍买卖,高手炒股技巧,让您在股市里买到好股票。V11:=MA(C,3)=LLV(MA(C,3),7);V12:=MA(C,3)<MA(C,5);V13:=MA(V,5)<MA(V,10)*0.99;V14:=COUNT(MA(C,2)<REF(C,2),2)=2;买 : IF(V11 AND V12 AND V13 ...
  • 关键字: