大智慧公式网收录大智慧公式,大智慧公式源码.域名http://www.yaoyaoyuan.cn
所在的位置: 大智慧公式网 > 通达信公式 > 正文

公式源码-通达信金端操盘主图指标公式(主图)

2013-12-10 00:00:00 通达信公式教程
摘要: 买好股公式文章通达信最好用的能量指标公式,介绍指标炒股技巧,让您在股市里买到好股票。MTM:=C-REF(C,1);主力做多:100*EMA(EMA(MTM,12),12)/EMA(EMA(ABS(MTM),12),12),COLORWHITE;多空趋势线:MA(主力做多,6),COLORYELLOW;能量:=主力做多-多空趋势线,COLORBLACK;持仓:能量,COLORRED;STICKLINE( UPNDAY(能量,1)AND ...负债,差值,财务,预警,系数通达信金端操盘主图指标公式主图 操盘 公式 指标 通达信DRAWBAND(MA(C,5),RGB(230,0,250),HHV(MA(C,5),13),RGB(0,100,150));F:=C/O;STICKLINE(F>=1,C,O,2.8,1),COLORRED;STICKLINE(F>=1,C,H,0.00001,0),COLORRED;STICKLINE(F>=1,L,O,0.00001,0),COLORRED;STICKLINE(F<1,C,O,2.8,0)

 

DRAWBAND(MA(C,5),RGB(230,0,250),HHV(MA(C,5),13),RGB(0,100,150));
F:=C/O;
STICKLINE(F>=1,C,O,2.8,1),COLORRED;
STICKLINE(F>=1,C,H,0.00001,0),COLORRED;
STICKLINE(F>=1,L,O,0.00001,0),COLORRED;
STICKLINE(F<1,C,O,2.8,0),COLORCYAN;
STICKLINE(F<1,O,H,0.00001,0),COLORCYAN;
STICKLINE(F<1,L,C,0.00001,0),COLORCYAN;

TYP := (HIGH + LOW + CLOSE)/3;
CCI1:=(TYP-MA(TYP,6))/(0.015*AVEDEV(TYP,6));
差值1:=ABS(REF(CCI1,1)-CCI1);
CCI2:=(TYP-MA(TYP,10))/(0.015*AVEDEV(TYP,10));
CCI3:=(TYP-MA(TYP,20))/(0.015*AVEDEV(TYP,20));
CCI4:=(TYP-MA(TYP,30))/(0.015*AVEDEV(TYP,30));
CCI5:=(TYP-MA(TYP,60))/(0.015*AVEDEV(TYP,60));
差值5:=ABS(REF(CCI5,1)-CCI5);
CCI:=CCI1+CCI2+CCI3+CCI4+CCI5;
AAA:=(3*C+H+L+O)/6;
VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)
+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
TJ111:=(ABS(CCI1)>CCI AND ABS( 差值1)> ABS(差值5))
OR (VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1);
VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
下跌:=IF(VAR1=VAR6,VAR6, DRAWNULL),COLORGREEN;
立桩量3:=FILTER(TJ111,5);
TJ222:=IF(BARSLAST(立桩量3)=1 AND CLOSE>REF(HIGH,1),1,
IF(BARSLAST(立桩量3)=2 AND CLOSE>REF(HIGH,2),1,
IF(BARSLAST(立桩量3)=3 AND CLOSE>REF(HIGH,3),1,0)));
突破3:=TJ222=1;
STICKLINE(CLOSE AND 下跌!= VAR6,REF(HIGH,BARSLAST(立桩量3)),
REF(HIGH,BARSLAST(立桩量3)),10,1),COLORGRAY;
STICKLINE(CLOSE AND 下跌!= VAR6,REF(LOW,BARSLAST(立桩量3)),
REF(LOW,BARSLAST(立桩量3)),10,1),COLORBROWN;
TJ3:=IF(BARSLAST(立桩量3)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量3)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量3)=3 AND CLOSE>REF(LOW,3),1,0)));
三天法则:=TJ3=1;
成立:=三天法则 AND 突破3;
条件成立:=FILTER(成立,5);
DRAWTEXT(条件成立 AND 下跌!= VAR6,H*1.005,'成立') COLORGRAY;

B1:=REF(C,1);B2:=REF(C,2);
SS:=IF(C>REF(C,1) AND REF(C,1)>=REF(C,2),1,IF(C<REF(C,1) AND REF(C,1)<=REF(C,2),-1,IF(C>REF(C,2) AND REF(C,2)>REF(C,1),2,IF(C<REF(C,2) AND REF(C,2)<REF(C,1),-2,0))));
SM:=IF(REF(SS,1)!=0,REF(SS,1),IF(REF(SS,2)!=0,REF(SS,2),IF(REF(SS,3)!=0,REF(SS,3),IF(REF(SS,5)!=0,REF(SS,5),IF(REF(SS,6)!=0,REF(SS,6),IF(REF(SS,7)!=0,REF(SS,7),0))))));
{STICKLINE(SS=1 OR SM>=1 AND SS=0,B1,C,2.8,0),COLORBLUE;
STICKLINE(SS=-1 OR SM<=-1 AND SS=0,B1,C,2.8,0),COLORYELLOW;
STICKLINE(SS=2,B2,C,2.8,0),COLORBLUE;
STICKLINE(SS=-2,B2,C,2.8,0),COLORYELLOW;}
STICKLINE((SS=-1 OR SS=-2) AND SM>0,B2,B1,2.8,0),COLORGREEN;
STICKLINE((SS=1 OR SS=2) AND SM<0,B2,B1,2.8,0),COLORMAGENTA;
AA:=CLOSE>REF(CLOSE,1) AND REF(CLOSE,1)>REF(CLOSE,2) AND REF(CLOSE,1)<REF(CLOSE,3) AND IF(REF(CLOSE,3)<REF(CLOSE,4),1,IF(REF(CLOSE,4)<REF(CLOSE,5),REF(CLOSE,1)<REF(CLOSE,4) OR (REF(CLOSE,2)<REF(CLOSE,4) AND REF(CLOSE,3)>=REF(CLOSE,5)),IF(REF(CLOSE,5)<REF(CLOSE,6),1,REF(CLOSE,6)<REF(CLOSE,7))));
BB:=CLOSE<REF(CLOSE,1) AND REF(CLOSE,1)<REF(CLOSE,2) AND REF(CLOSE,1)>REF(CLOSE,3) AND IF(REF(CLOSE,3)>REF(CLOSE,4),1,IF(REF(CLOSE,4)>REF(CLOSE,5),REF(CLOSE,1)>REF(CLOSE,4) OR (REF(CLOSE,2)>REF(CLOSE,4) AND REF(CLOSE,3)<=REF(CLOSE,5)),IF(REF(CLOSE,5)>REF(CLOSE,6),1,REF(CLOSE,6)>REF(CLOSE,7))));
DRAWTEXT(AA AND CLOSE>REF(OPEN,2),LOW*0.97,'三平底'),COLORWHITE;
DRAWTEXT(BB AND CLOSE<REF(CLOSE,2),HIGH*1.03,'三平顶'),COLORCYAN;

操作:HHV(MA(CLOSE,5),13),COLORGREEN;
MA5:MA(CLOSE,5) COLORWHITE;
MA10:MA(CLOSE,10) COLORYELLOW;
MA20:MA(CLOSE,20) COLORMAGENTA;
MA60:MA(CLOSE,60) COLORCYAN;

OC:=REF(CLOSE,1);
RSV:=(((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9)))*100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
YX:=((CLOSE>OC) AND C>O);
KK:=HHV(K,5);
HH:=HHV(D,5);
D1:=REF(D,1);
K1:=REF(K,1);
DRAWTEXT((((D1<30) AND CROSS(K,D)) AND YX),(LOW * 0.98),'←短买!'),COLORYELLOW;

VAR11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)
-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
黑码线:=EMA(VAR11,5), LINETHICK2,COLOR6600FF;
黑码线2:=100*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60)),LINETHICK2,,;
DRAWTEXT(CROSS(黑码线,黑码线2),L*0.95,'追涨'),COLORRED;
VARP1:=(C+H+O+L)/4;
卖出:XMA(VARP1,20)*(1+80/1000),POINTDOT,COLORGREEN,LINETHICK3;
买入:XMA(VARP1,32)*(1-100/1000),POINTDOT,COLORMAGENTA,LINETHICK3;
中线:(卖出+买入)/2,POINTDOT,COLORWHITE,LINETHICK3;
{股灵吧决策}
VAR100:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));
VAR200:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));
VAR300:=(100 - MA(((100 * (HHV(HIGH,5) - CLOSE)) / (HHV(HIGH,5) - LLV(LOW,5))),34));
FF:IF(CROSS(VAR200,MA(VAR300,5)),LOW * 0.98,DRAWNULL),CROSSDOT,LINETHICK3,COLOREE00EE;
DRAWTEXT(CROSS(VAR200,MA(VAR300,5)),LOW*0.97,'入货'),COLORYELLOW;

{N:=0.98;
VAR4:=PEAKBARS(3,15,1)<10;
VAR5:=IF(VAR4=1,2,0);
顶:= IF(VAR5=2,2,0);
中线卖出:=IF(顶>REF(顶,1),1,0);
止损价:=IF(中线卖出=1, C*N,0), POINTDOT,COLOR00FF00,LINETHICK5;
STICKLINE(止损价,C*N,C*N,200,1),COLORRED,LINETHICK1;}{画线}

{AA1:=MA(C,5);
BB1:=MA(C,15);
AF:=CROSS(AA1,BB1);
STICKLINE(AF,LLV(L,4),LLV(L,4),50,1),COLORRED,LINETHICK3;
DRAWTEXT(AF,LLV(L,4),'止损线'),COLORYELLOW;};

{业绩综合}
市盈率:=STRCAT('市盈率: ',CON2STR(C/FINANCE(33),2));
市销率:=STRCAT(' 市销率: ',CON2STR(C/(FINANCE(20)/FINANCE(1)),2));
市净率:=STRCAT(' 市净率: ',CON2STR(C/FINANCE(34),2));
净资收益率:=STRCAT(' 净资收益率: ',CON2STR(FINANCE(33)/FINANCE(34)*100,2));
毛利率:=STRCAT(' 毛利率: ',CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));
净利润率:=STRCAT(' 净利润率 ',CON2STR(FINANCE(30)/FINANCE(20)*100,2));
主营利润率:=STRCAT(' 主营利润率 ',CON2STR(FINANCE(23)/FINANCE(20)*100,2));
当前业绩:=STRCAT('当前业绩: ',STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(市销率,市净率),净资收益率),毛利率),净利润率),主营利润率));
DRAWTEXT_FIX(ISLASTBAR,0.00,0.24,0,当前业绩),COLORLIMAGENTA;
{风险系数}
X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替};
X3:=FINANCE(23)/FINANCE(10)*3.3;
X4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}
X5:=FINANCE(20)/FINANCE(15)*0.999;
Z值:=X1+X2+X3+X4+X5;
预警:=IF(Z值<1.2,'重警',IF(Z值>=1.2 AND Z值<2.6,'轻警','无警'));
财务预警:=STRCAT('财务预警: ',STRCAT(预警,STRCAT('-Z值: ',CON2STR(Z值,3))));
优质资产率:=STRCAT(' 优质资产率: ',CON2STR((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19),2));{理论上越大越好但不同行业有不同标准};
现金负债比:=STRCAT(' 现金负债比: ',CON2STR(FINANCE(25)/FINANCE(15),3));{缺长期负债或负债总额,理论上越大越好但不同行业有不同标准};
财务系数:=STRCAT('风险系数: ',STRCAT(STRCAT(财务预警,优质资产率),现金负债比));
DRAWTEXT_FIX(ISLASTBAR,0.46,100,0,财务系数),COLORGRAY;
{}
DRAWTEXT_FIX(1,0.00,0,0,DYBLOCK)COLOR00FFFF;
DRAWTEXT_FIX(1,0.1,0,0,HYBLOCK)COLOR0080FF;
{上市天数:=STRCAT('上市日期:',CON2STR(FINANCE(42),0));
DRAWTEXT_FIX(ISLASTBAR,0.2,0.0,0,上市天数),COLORGREEN;}
DRAWTEXT_FIX(1,0.2,0.0,0,'上市日期:'),COLORLIGREEN;
DRAWNUMBER_FIX(1,0.28,0.0,0,CONST(FINANCE(42))),COLORLIGREEN;

DRAWTEXT_FIX(1,0.4,0.0,0,'证券会行业:')COLORLICYAN;DRAWTEXT_FIX(1,0.49,0.0,0,EXTERNSTR(0,4)),COLORLICYAN;
DRAWTEXT_FIX(1,0.00,0.06,0,'主营业务:')COLOR0000FF;DRAWTEXT_FIX(1,0.08,0.06,0,EXTERNSTR(0,1))COLOR0000FF;
DRAWTEXT_FIX(1,0.0,0.12,0,'主题概念:')COLORFF00FF;DRAWTEXT_FIX(1,0.08,0.12,0,EXTERNSTR(0,2))COLORFF00FF;
DRAWTEXT_FIX(1,0.00,0.18,0,'主题投资:')COLORFF88FF;DRAWTEXT_FIX(1,0.08,0.18,0,EXTERNSTR(0,3))COLORFF88FF;
{DRAWTEXT_FIX(1,0.00,0.85,0,'愚民概念:')COLORWHITE;DRAWTEXT_FIX(1,0.08,0.85,0,EXTERNSTR(0,5))COLORWHITE;}


{财务分折}
DRAWTEXT_FIX(1,0.00,100,0,'财务分折:')COLORMAGENTA;
DRAWTEXT_FIX(1,0.08,100,0,'现金流:'),COLOR00CCCC;
DRAWNUMBER_FIX(1,0.14,100,0,CONST(FINANCE(25)/1000000000)),COLOR00CCCC;
DRAWTEXT_FIX(1,0.2,100,0,'流动比率:'),COLOR00CCCC;{流动比率值>1.5<2.5较为合理,低于1说明偿债能力欠佳。}
DRAWNUMBER_FIX(1,0.27,100,0,CONST(FINANCE(11)/FINANCE(15))),COLOR00CCCC;
DRAWTEXT_FIX(1,0.33,100,0,'速动比率:'),COLOR00CCCC;
DRAWNUMBER_FIX(1,0.4,100,0,CONST((FINANCE(11)-FINANCE(27))/FINANCE(15))),COLOR00CCCC;






  声明:本站部分内容来自合作媒体及网络,不代表本站观点。本站不对上述言论承担责任。关键字:负债,差值,财务,预警,系数
相关阅读:
  • >>公式源码:通达信周KDJ指标公式(公式)
    买好股公式文章通达信周KDJ指标公式,介绍KDJ炒股技巧,让您在股市里买到好股票。周J1:=MA("KDJ.J#WEEK"(9,3,3) ,5);STICKLINE(周J1>0,周J1,0,2,周J1);DRAWICON(CROSS(周J1,68),周J1*2.03,1);DRAWICON(CROSS(周J1,5),周J1*-0.92,5);...
  • >>源码-通达信阶段底部选股公式源码(公式)
    买好股公式文章通达信阶段底部选股公式源码,介绍底部,选股,源码炒股技巧,让您在股市里买到好股票。操作说明:偶的一个公式中提出的小东东,简单改一下,分析趋势还不错,分享给童鞋,选股买票重要一条是看票的趋势,选择向上走趋势票会有...
  • >>指标公式:同花顺魔鬼操盘主图公式源码(主图)
    买好股公式文章同花顺魔鬼操盘主图公式源码,介绍同花顺,操盘,主图,公式,源码炒股技巧,让您在股市里买到好股票。均5:MA(CLOSE,5), coloryellow;{www。zhibiao8。com 指标公式}均10:MA(CLOSE,10), COLORf00ff0;均30: MA(CLOSE,30), COLOR00...
  • 关键字: