大智慧公式网收录大智慧公式,大智慧公式源码.域名http://www.yaoyaoyuan.cn
所在的位置: 大智慧公式网 > 通达信公式 > 正文

指标公式:通达信最好的主图成功率很高指标公式(主图)

2013-12-10 00:00:00 通达信公式教程
摘要: 买好股公式文章通达信强弓之末天地量比逃顶指标公式主图源码,介绍地量,逃顶,公式,主图,源码炒股技巧,让您在股市里买到好股票。{同花顺公式网选编}首发一个本人原创的逃顶指标:天量地量之比>30倍时逃顶。注意:这个条件不是每个顶都合适,但只要符合条件,就有一定的参考价值(不足之处就是会放走极少数超强股)。...逃顶,负债,市值,预警,毛利率通达信最好的主图成功率很高指标公式主图 公式 指标 成功 通达信多:EMA(C,3),COLORYELLOW;空:EMA(C,5),COLOR00FF00;均衡:EMA(空,5),COLORWHITE,;VARF1:=COUNT(CROSS(多,均衡),2)=1;VARF2:=COUNT(CROSS(空,均衡),2)=1;ZAI:=FILTER(VARF1 AND VARF2,2);DRAWTEXT(ZAI,均衡,主升↑),COLORFF00FF;VV2:



多:EMA(C,3),COLORYELLOW;
空:EMA(C,5),COLOR00FF00;
均衡:EMA(空,5),COLORWHITE,;
VARF1:=COUNT(CROSS(多,均衡),2)=1;
VARF2:=COUNT(CROSS(空,均衡),2)=1;
ZAI:=FILTER(VARF1 AND VARF2,2);
DRAWTEXT(ZAI,均衡,'主升↑'),COLORFF00FF;
VV2:=REF(CLOSE,1);
VV3:=SMA((CLOSE-VV2),6,1)/SMA(ABS(CLOSE-VV2),6,1)*100;
DRAWICON(REF(VV3,1)>81 AND VV3<80,HIGH,2);
DRAWTEXT(REF(VV3,1)>81 AND VV3<80,HIGH*1.03,'沽空↓'),COLORYELLOW;
VF1:=MA(CLOSE,60)-MA(CLOSE,5)/3.2;
DRAWTEXT(IF(CLOSE<VF1 AND VOL/240>MA(VOL,5)/240 AND CLOSE>=REF(CLOSE,1)*1.08 AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW,'☆'),COLORRED;
VARA:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
VARB:=EMA(0.667*REF(VARA,1)+0.333*VARA,5);
DRAWTEXT(IF(VOL>=1.3*MA(VOL,5) AND COUNT(VARA>=VARB AND VARA<-17,3) AND REF(LOW,1)=LLV(LOW,120),1,0),LOW,'★注意买入');
VARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,VARR1),HIGH,2);
DRAWTEXT(CROSS(82,VARR1),HIGH,'短空↓'),COLORYELLOW;
VAR1:=(HIGH+LOW+OPEN+2*CLOSE)/5;
VAR2:=REF(VAR1,1);
VAR3:=SMA(MAX(VAR1-VAR2,0),10,1)/SMA(ABS(VAR1-VAR2),10,1)*100;
HY3:=IF(COUNT(VAR3<20,5)>=1 AND COUNT(VAR1=LLV(VAR1,10),10)>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0);
DRAWTEXT(HY3,LOW,'注意买入'),COLORRED;
S:=MA(VOL,5)/MA(VOL,60),COLORRED,,LINETHICK2;
A:=MA(S,5),COLORGREEN,,LINETHICK2;
BIAS:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;
F:=MA(S,121);
RSV:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;
K:=SMA(RSV,15,1);
D:=SMA(K,15,1);
J:=3*K-2*D;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT(CROSS(84,RSI) , HIGH*1.06,'逃顶!'),COLORYELLOW ;
S1:=IF((J<11 AND BIAS>-11 AND CROSS( S,F) AND (S-F)>0.010),2,0),STICK,LINETHICK3,COLORGREEN;
DRAWTEXT(S1=2,LOW,'关注'), COLORGREEN;
中轨:HHV(MA(H,13),13),COLORRED,LINETHICK2;
趋势:LLV(MA(H,13),1),COLORGREEN,LINETHICK2;
DRAWTEXT_FIX(1,0.00,0.155,0,'主题投资:')COLOR0000FF;
DRAWTEXT_FIX(1,0.07,0.155,0,EXTERNSTR(0,1))COLOR0000FF;
DRAWTEXT_FIX(1,0.00,0.21,0,'主营业务:')COLORFF00FF;
DRAWTEXT_FIX(1,0.07,0.21,0,EXTERNSTR(0,2))COLORFF00FF;
总股本:=STRCAT(STRCAT('总股本: ',CON2STR(TOTALCAPITAL/1000000,2)),'亿');
流通盘:=STRCAT(STRCAT(' 流通盘: ',CON2STR(CAPITAL/1000000,2)),'亿');
全流通:=STRCAT(' 全流通: ',CON2STR((CAPITAL/1000000)/(TOTALCAPITAL/1000000),2));
市值:=STRCAT(STRCAT(' 流通市值: ',CON2STR((CAPITAL/1000000)*C,2)),'亿');
上市日期:=STRCAT(' 上市天数: ',CON2STR(FINANCE(42),0));
股本市值:=STRCAT('股本市值: ',STRCAT(STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值),上市日期));
{}
市盈率:=STRCAT('市盈率: ',CON2STR(C/FINANCE(33),2));
市销率:=STRCAT(' 市销率: ',CON2STR(C/(FINANCE(20)/FINANCE(1)),2));
市净率:=STRCAT(' 市净率: ',CON2STR(C/FINANCE(34),2));
净资收益率:=STRCAT(' 净资收益率: ',CON2STR(FINANCE(33)/FINANCE(34)*100,2));
毛利率:=STRCAT(' 毛利率: ',CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));
净利润率:=STRCAT(' 净利润率 ',CON2STR(FINANCE(30)/FINANCE(20)*100,2));
主营利润率:=STRCAT(' 主营利润率 ',CON2STR(FINANCE(23)/FINANCE(20)*100,2));
利润同比:=STRCAT(' 利润同比: ',CON2STR(FINANCE(43),2));
收入同比:=STRCAT(' 收入同比: ',CON2STR(FINANCE(44),2));
当前业绩:=STRCAT('当前业绩: ',STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(市盈率,市销率),市净率),净资收益率),毛利率),净利润率),主营利润率), 利润同比), 收入同比));
{}
X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替};
X3:=FINANCE(23)/FINANCE(10)*3.3;
X4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}
X5:=FINANCE(20)/FINANCE(15)*0.999;
Z值:=X1+X2+X3+X4+X5;
预警:=IF(Z值<1.2,'重警',IF(Z值>=1.2 AND Z值<2.6,'轻警','无警'));
财务预警:=STRCAT('财务预警: ',STRCAT(预警,STRCAT('-Z值: ',CON2STR(Z值,3))));
优质资产率:=STRCAT(' 优质资产率: ',CON2STR((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19),2));{理论上越大越好但不同行业有不同标准};
现金负债比:=STRCAT(' 现金负债比: ',CON2STR(FINANCE(25)/FINANCE(15),3));{缺长期负债或负债总额,理论上越大越好但不同行业有不同标准};
财务系数:=STRCAT('风险系数: ',STRCAT(STRCAT(财务预警,优质资产率),现金负债比));
{}
DRAWTEXT_FIX(ISLASTBAR,0.005,0.01,0,财务系数),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.06,0,当前业绩),COLORLIMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.115,0,股本市值),COLORYELLOW;






  声明:本站部分内容来自合作媒体及网络,不代表本站观点。本站不对上述言论承担责任。关键字:逃顶,负债,市值,预警,毛利率
相关阅读:
  • >>指标公式:通达信突然放量副图指标公式(副图)
    1、数字表示当日成交量是30、60、120和250天以来最大的量(例如:1表示当日为30天的最大量);2、数字出现的次数多、且K线为连续阳线是首选;(公式里有选股公式、可直接使用排序)3、适用于双底或多重底形态、且底部呈抬高状态;4、基...
  • >>公式:通达信极准的中线指标公式(中线)
    买好股公式文章通达信极准的中线指标公式,介绍中线炒股技巧,让您在股市里买到好股票。非常准的一个指标,用法:见白色针即可准备,冲破前高买入RSV:=(CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100;K:=SMA(RSV,9,1);D:=SMA(K...
  • >>源码-凯恩斯双线制胜操作与公式源码(凯恩斯)
    凯恩斯双线制胜操作与公式源码双线制胜操作法=工作线+生命线 所谓“工作线”,顾名思义,就是工作线上“上班工作”,工作线下就“下班休息”。选定14日或者18日均线作为工作线的区别是:如果做短线,14日线作为工作线线最有效,因为它提供...
  • 关键字: