大智慧公式网收录大智慧公式,大智慧公式源码.域名http://www.yaoyaoyuan.cn
所在的位置: 大智慧公式网 > 通达信公式 > 正文

源码-通达信顶底买卖副图指标公式(副图)

2013-11-24 00:00:00 通达信公式教程
摘要: bk:='A股板块'; //bk赋值为字符串'A股板块'yygs:='bias.bias1';//引用的指标,此处可修改为引用其它的指标stksum:=STKCOUNT(bk); //板块所包含证券数量dcount:=datacount; //K线图上,最后一根K线的位置variable:dmstr[stksum]='',var_px[stksum]=0,var_indi[stksum]=0; //定义一个字符串数组用于记录股票代码,元素...股价,趋势,买入,信号,抄底通达信顶底买卖副图指标公式副图 公式 指标 买卖 通达信P1:=-6;{ www,jiachenglong,cn 通达信指标公式网}BIAS1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;BIAS2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;BIAS3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;MM:=(BIAS1+2*BIAS2+3*BIAS3)/6;股价趋势:MA

P1:=-6;
{ www,jiachenglong,cn 通达信指标公式网}
BIAS1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIAS2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
BIAS3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
MM:=(BIAS1+2*BIAS2+3*BIAS3)/6;
股价趋势:MA(MM,3),COLORRED;
买入信号:EMA(股价趋势,2);
抄底:IF(股价趋势<P1,-11,-15),COLORFF00FF;
DRAWTEXT(CROSS(股价趋势,买入信号) AND COUNT(买入信号<P1,2)>1,-10,'△'),COLORRED,LINETHICK3;
STICKLINE((股价趋势<-9),0,-15,4,0 ),COLORCC0033;
STICKLINE((股价趋势<-9),0,-11,4,0 ),COLORFF9966;
底部预警信号:
STICKLINE( (股价趋势<-9),0,-6,4,0) ,COLORFFCC66;
STICKLINE( (股价趋势<-9),0,-2,4,0 ),COLORFFFF66;
XY1272:
STICKLINE((股价趋势<-12),10 ,-15,4,0) ,COLOR0066FF;
STICKLINE((股价趋势<-12),10 ,-5,4,0 ),COLOR0099FF;
STICKLINE((股价趋势<-12),10 ,0,4,0 ),COLOR00CCFF;
STICKLINE((股价趋势<-12),10 ,3,4,0),COLOR00FFFF;

AA:=1;
VAR1:=10;
VAR2:=11;
VAR3:=11;
VAR4:=12;
VAR5:=12;
VAR6:=13;
VAR7:=13;
VAR8:=14;
VAR9:=14;
VARA:=15;
VARB:=15;
VARC:=SMA((CLOSE-LLV(LOW,VAR1))/(HHV(HIGH,VAR1)-LLV(LOW,VAR1))*100,4,1);
VARD:=SMA((CLOSE-LLV(LOW,VAR2))/(HHV(HIGH,VAR2)-LLV(LOW,VAR2))*100,4,1);
VARE:=SMA((CLOSE-LLV(LOW,VAR3))/(HHV(HIGH,VAR3)-LLV(LOW,VAR3))*100,4,1);
VARF:=SMA((CLOSE-LLV(LOW,VAR4))/(HHV(HIGH,VAR4)-LLV(LOW,VAR4))*100,4,1);
VAR10:=SMA((CLOSE-LLV(LOW,VAR5))/(HHV(HIGH,VAR5)-LLV(LOW,VAR5))*100,4,1);
VAR11:=SMA((CLOSE-LLV(LOW,VAR6))/(HHV(HIGH,VAR6)-LLV(LOW,VAR6))*100,4,1);
VAR12:=SMA((CLOSE-LLV(LOW,VAR7))/(HHV(HIGH,VAR7)-LLV(LOW,VAR7))*100,4,1);
VAR13:=SMA((CLOSE-LLV(LOW,VAR8))/(HHV(HIGH,VAR8)-LLV(LOW,VAR8))*100,4,1);
VAR17:=SMA((CLOSE-LLV(LOW,VARB))/(HHV(HIGH,VARB)-LLV(LOW,VARB))*100,4,1);
VAR18:=(HIGH+LOW+CLOSE)/3;
VAR19:=(VAR18-MA(VAR18,14))/(0.015*AVEDEV(VAR18,14));
VAR1A:=(VAR18-MA(VAR18,70))/(0.015*AVEDEV(VAR18,70));
VAR1B:=IF(VAR19>=150 AND VAR19<200 AND VAR1A>=150 AND VAR1A<200,-10,0);
VAR1C:=IF(VAR19<=-150 AND VAR19>-200 AND VAR1A<=-150 AND VAR1A>-200,10,0);
VAR1D:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR1E:=100-ABS(VAR1D);
(IF(BARSCOUNT(CLOSE)<13,100,IF(VAR1E<88 AND VAR1D>0,85,100)))*AA,COLORFFFF00;
(IF(BARSCOUNT(CLOSE)<13,-100,-IF(VAR1E<92 AND VAR1D<0,85,100)))*(AA),COLORYELLOW;
(IF(BARSCOUNT(CLOSE)<70,120,(IF(VAR1A>=200 AND VAR19>=150,-15,VAR1B))+120))*AA,LINETHICK2,COLOR0000FF;
出:(IF(BARSCOUNT(CLOSE)<70,-120,(IF(VAR1A<=-200 AND VAR19<=-150,15,VAR1C))-120))*(AA),LINETHICK2,COLOR00FF00;





  声明:本站部分内容来自合作媒体及网络,不代表本站观点。本站不对上述言论承担责任。关键字:股价,趋势,买入,信号,抄底
相关阅读:
  • >>[指标]通达信平安分时追涨追击涨停指标公式(分时)
    买好股公式文章通达信平安分时追涨追击涨停指标公式,介绍分时,追涨,把握,强势,强势股,股票,涨停炒股技巧,让您在股市里买到好股票。《平安分时追涨》,优于其他众多分时追涨指标,指标设计的理念是有资金介入,买盘力度大的股票作为标的,...
  • >>源码-飞狐逃离苦海公式源码(飞狐)
    买好股公式文章飞狐逃离苦海公式源码,介绍炒股技巧,让您在股市里买到好股票。AA:=MA(WINNER(CLOSE*0.95)*100,3); {大智慧公式网选编}Var1:=1/WINNER(CLOSE); Var2:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100; Var3:=100-ABS(Var2); Var4:=3...
  • >>公式-大智慧无名主图实战性强指标公式(主图)
    买好股公式文章大智慧无名主图实战性强指标公式,介绍主图,实战炒股技巧,让您在股市里买到好股票。{同花顺公式网选编}时间之窗(易学公式)农历年:LYEAR,LINETHICK0,colorFF00FF;农历月:LMONTH,LINETHICK0,colorFF9900;农历日:LDAY,LINETH...
  • 关键字: