大智慧公式网收录大智慧公式,大智慧公式源码.域名http://www.yaoyaoyuan.cn
所在的位置: 大智慧公式网 > 通达信公式 > 正文

公式源码:通达信经典对比终结版副图公式源码(副图)

2013-11-18 00:00:00 通达信公式教程
摘要: 买好股公式文章大智慧收集比较不错的主副图公式源码,介绍大智慧炒股技巧,让您在股市里买到好股票。这几年见到感觉还行的指标就存下了,现在都发出来供同学挑选,不管是从实用角度还是学习指标编写的角度,相信总有一款是你喜欢的。{公式源码网选编}在下载后一定要参与评价:给贴主“推荐”评价一次,贴主得一个...负债,预警,系数,财务,现金通达信经典对比终结版副图公式源码副图 公式 源码 经典 通达信DRAWBAND(20,RGB(25,60,68),10,RGB(0,0,0));DRAWBAND(90,RGB(25,60,68),80,RGB(0,0,0));DPK30:=SMA(((INDEXC-LLV(INDEXL,30))/(HHV(INDEXH,30)-LLV(INDEXL,30))*100),3,1),COLORGRAY;K30:=SMA(((CLOSE-LLV(LOW,30))/(HHV(

DRAWBAND(20,RGB(25,60,68),10,RGB(0,0,0));
DRAWBAND(90,RGB(25,60,68),80,RGB(0,0,0));
DPK30:=SMA(((INDEXC-LLV(INDEXL,30))/(HHV(INDEXH,30)-LLV(INDEXL,30))*100),3,1),COLORGRAY;
K30:=SMA(((CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100),3,1);
关注区:IF(K30>DPK30 AND K30>=50,46,DRAWNULL),CIRCLEDOT,COLORFF00FF;
STICKLINE(K30>=50,50,K30,3,0),COLOR000080;
STICKLINE(K30>=50,50,K30,2,0),COLOR0000A6;
STICKLINE(K30>=50,50,K30,1,0),COLOR0000CE;
STICKLINE(K30>=50,50,K30,0,0),COLOR0000FF;
STICKLINE(K30<50,50,K30,3,0),COLOR800000;
STICKLINE(K30<50,50,K30,2,0),COLORB00000;
STICKLINE(K30<50,50,K30,1,0),COLORD50000;
STICKLINE(K30<50,50,K30,0,0),COLORFF0000;
{DRAWBAND(K30,RGB(150,20,20),50,RGB(10,150,20));}
个股:K30,NODRAW,COLORRED;
大盘:DPK30,COLORYELLOW,DOTLINE;
K250:SMA(((CLOSE-LLV(LOW,250))/(HHV(HIGH,250)-LLV(LOW,250))*100),3,1),COLORGREEN;
DRAWICON(CROSS(90,K30),K30,2);
DRAWICON(CROSS(K30,大盘) AND K30<50,K30,1);
DRAWTEXT(CROSS(K30,K250),42,'转强');
DRAWTEXT(FILTER(CROSS(10,K30),20),42,'吸'),COLOR00C0FF;
DRAWTEXT(FILTER(CROSS(10,K30),20),30,'筹'),COLORFFFF6F;
DRAWTEXT(FILTER(CROSS(10,K30),20),20,'区'), COLORB47DFF;
A1:=LLV(LOW,6)=LLV(LOW,41) AND LLV(LOW,6)<HHV(LOW,41)*71/100;
B2:=HIGH>LOW*1.033;DRAWICON(A1>0 AND B2,86,1);
{年月日星期}
D1:=YEAR AND MONTH AND DAY ;
AA1:=STRCAT(CON2STR(YEAR,0),'年');
AA2:=STRCAT(CON2STR(MONTH,0),'月');
AA3:=STRCAT(CON2STR(DAY,0),'日');
AA4:=STRCAT('星期',IF(WEEKDAY=1,'一',IF(WEEKDAY=2,'二',
IF(WEEKDAY=3,'三',IF(WEEKDAY=4,'四',IF(WEEKDAY=5,'五',
IF(WEEKDAY=6,'六','日')))))));
AA:=STRCAT(STRCAT(STRCAT(AA1,AA2),STRCAT(AA3,AA4)),'');
DRAWTEXT_FIX(D1,0.01,0.03,0,AA),COLORMAGENTA;


{风险系数}
X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替};
X3:=FINANCE(23)/FINANCE(10)*3.3;
X4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}
X5:=FINANCE(20)/FINANCE(15)*0.999;
Z值:=X1+X2+X3+X4+X5;
预警:=IF(Z值<1.2,'重警',IF(Z值>=1.2 AND Z值<2.6,'轻警','无警'));
财务预警:=STRCAT('财务预警: ',STRCAT(预警,STRCAT('-Z值: ',CON2STR(Z值,3))));
优质资产率:=STRCAT(' 优质资产率: ',CON2STR((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19),2));{理论上越大越好但不同行业有不同标准};
现金负债比:=STRCAT(' 现金负债比: ',CON2STR(FINANCE(25)/FINANCE(15),3));{缺长期负债或负债总额,理论上越大越好但不同行业有不同标准};
财务系数:=STRCAT('风险系数: ',STRCAT(STRCAT(财务预警,优质资产率),现金负债比));
DRAWTEXT_FIX(ISLASTBAR,0.00,0.82,0,财务系数),COLORYELLOW;
 


 






 



  声明:本站部分内容来自合作媒体及网络,不代表本站观点。本站不对上述言论承担责任。关键字:负债,预警,系数,财务,现金
相关阅读:
  • >>[指标]飞狐上马骑马副图公式源码(副图)
    马线变为红色看清位置可上马,红变青要下马,骑马线上穿马线看清方向可骑马.均价:=(2*C+(C+H+L+O)/4+O)/4;R:=(2*L+3*均价)/5;R1:=(2*H+3*均价)/5;kx:=(R+r1)/2;上马:=3*SMA((kx-LLV(R,54))/(HHV(R1,54)-LLV(R,54))*100,5,1)-2*SMA((kx-LLV(R...
  • >>公式:大智慧主图极品大礼主图公式源码(主图)
    主图极品大礼 主图源码{大智慧公式网}07年至今一直在论坛潜心修炼,受到很多老师教诲,收益匪浅。一直有一个愿望,想形成自己风格的主图,殚精竭虑、费尽心思。 时至至今,保留的主图成百上千,时过境迁,但唯独这个主图始终不离左右,可...
  • >>源码-通达信换手率量柱公式源码(换手率)
    买好股公式文章通达信换手率量柱公式源码,介绍通达信,换手率,公式,源码炒股技巧,让您在股市里买到好股票。虚拟换手率:IF(CURRBARSCOUNT=1,(100*V/(FINANCE(7)/100))*(IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PER...
  • 关键字: