大智慧公式网收录大智慧公式,大智慧公式源码.域名http://www.yaoyaoyuan.cn
所在的位置: 大智慧公式网 > 通达信公式 > 正文

公式源码:精品:通达信黑马必胜主图公式源码(主图)

2013-10-20 00:00:00 通达信公式教程
摘要: 均价:=(C+(C+H+L+O)/4+O)/3;操盘线:EMA(MA(IF(MA(均价,3)>MA(均价,4),MA((均价+3*H)/4,3),REF(MA((均价+3*L)/4,3),1)),3),5),COLORWHITE,LINETHICK2;A1:REF(操盘线,1), COLOR8A8A8A;A2:REF(操盘线,2), COLOR898989;A3:REF(操盘线,3), COLOR888888;A4:REF(操盘线,4), COLOR878787;A5:REF(操盘线,5), COLOR868686;A6:...逃顶,买点,买入,均衡,卖点精品:通达信黑马必胜主图公式源码主图 必胜 黑马 公式 源码黑码指标公式,自己用了多年了{大阴线:大跌超2.3}C2:=REF(C,1);BG:=IF((C2-C)*100/C2>=2.3,1,0) OR IF((O-C)*100/O>=5,1,0){ OR IF((H-L)*100/REF(C,1)>5,1,0)};{第二个条件开盘价过高掉下来}BG2:=IF((H-L)*100/C2>=3.58,1,0);BB1:=L

黑码指标公式,自己用了多年了



{大阴线:大跌超2.3}  C2:=REF(C,1);  BG:=IF((C2-C)*100/C2>=2.3,1,0) OR IF((O-C)*100/O>=5,1,0){ OR IF((H-L)*100/REF(C,1)>5,1,0)};{第二个条件开盘价过高掉下来} BG2:=IF((H-L)*100/C2>=3.58,1,0);  BB1:=L<REF(L,1);  {卖点信号} SELL1:=BG AND BB1 ;  {大阳线:升幅超2.64}  BR:=IF((C-C2)*100/C2>=2.59,1,0) OR IF((C-O)*100/O>=4.5,1,0) OR IF((C-L)*100/L>5,1,0);{第二个条件开盘价太低升上来}  {STICKLINE(BR,O,C,3,0),COLORRED;}  {以下条件记住最近一次卖出点} DAY1:=BARSLAST(SELL1);  JIA1:=REF(O,DAY1);  JIA2:=REF(O,1);  BB4:=C>JIA2;  BB2:=H>JIA1;  {买入信号} BUY1:=BR AND BB2  AND BB4;  {记住最后一次买点} DAY2:=BARSLAST(BUY1);  {买卖谁先} S1:=DAY1<DAY2;  B1:=DAY2<DAY1;  {其它补充1:买点} AA2:=AMOUNT/VOL;  BB3:=L<AA2*0.9;  CC2:=(C-REF(C,1))/REF(C,1)*100>1.2;  DD2:=L<MA(C,6)*0.921;  DD1:=L<MA(C,5)*0.921;  EE2:=VOL<MA(V,5)*1.5;  FF2:=BB3 AND CC2 AND DD2 AND EE2; 老鼠仓:=BB3 AND CC2 AND DD1 AND EE2,LINETHICK0,COLOR0099FF;  DRAWTEXT(老鼠仓,L*0.97,'老鼠仓'),COLOR0099FF;  DRAWTEXT(FF2,L*0.99,'买点'),COLOR00FFFF;  {STICKLINE(FF2,H,L,0.3,0),COLOR00FFFF;  STICKLINE(FF2,O,C,3,1),LINETHICK2,COLOR00FFFF;}  {检查买点是否成立} B4:=BARSLAST(FF2);{底点日期} E4:=B4<5;{5日内的线} F4:=E4 AND C>REF(C,1);  {STICKLINE(F4,H,L,0.3,0),COLOR00FFFF;}  {其它补充2:卖点} A2:=(C-REF(C,1))/REF(C,1)*100<1.02;  A3:=H>MA(C,5)*1.12;  AA:= A2 AND A3;  DRAWTEXT(AA,H*1.05,'卖点'),COLORFF0000;  {STICKLINE(AA,H,L,0.3,0),COLORFF0000;  STICKLINE(AA,H,L,3,0),COLORFF0000;};  {补充阳光买点} VAR1:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)- 3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1);  VAR2:=8;  CC:=CROSS(VAR1,VAR2);  CCC:=CROSS(VAR1,VAR2) AND H>REF(H,1) AND C>REF(C,1) ;  DRAWICON(CCC,L*0.99,1);  {STICKLINE(CC,H,L,0.3,0),COLORRED;  STICKLINE(CC,O,C,3,1),LINETHICK2,COLORRED;}  {加强买点后续升势} CF1:=BARSLAST(CC);{买点日期} CF2:=CF1<3;{5日内的线} CF3:=CF2 AND C>REF(C,1);  {STICKLINE(CF3,O,C,3,0),COLOR00FFFF;}  CD:=CROSS(VAR2,VAR1);  {STICKLINE(CD,H,L,0.3,0),COLORYELLOW;  STICKLINE(CD,O,C,3,1),LINETHICK2,COLORYELLOW;}  DRAWTEXT(CD,H*1.01,'准备'),COLORYELLOW;  DRAWTEXT(CC,L*0.98,'买'),COLORFF00FF;{输出粉红色的买字};  {牛窝} VAR1A:=LLV(LOW,21);  VAR2A:=HHV(HIGH,21);  AK1:=EMA((((CLOSE - VAR1A) / (VAR2A - VAR1A)) * 100),5);  AK:=EMA((((CLOSE - VAR1A) / (VAR2A - VAR1A)) * 50),13);  AB:=CROSS(AK1,AK);  DRAWTEXT((AB = 1),(LOW * 0.95),'○牛窝'),COLORYELLOW;  {大胆博、加仓、小心变盘、逃顶} VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);  VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);  DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.93),'★大胆搏 '),COLOR00FFFF;  DRAWTEXT(FILTER((VAR4AA>90),35),(LOW)*(0.99000001),'★加仓'),COLOR00FFFF;  A1AA:=9;  A2AA:=(REF(CLOSE,A1AA+1)<CLOSE);  DRAWTEXT(FILTER((A2AA>-0.5),84),(HIGH)*(1.05),'小心变盘'),COLORFFFFFF;  VAR6:=REF(C,1);  VAR7:=SMA(MAX(C-VAR6,0),6,1)/SMA(ABS(C-VAR6),6,1)*100;  DRAWTEXT(CROSS(82,VAR7),H*1.02,'逃顶'),COLORYELLOW;  {主力进场} VAR9:=((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100);  VAR10:=SMA(VAR9,3,1);  VAR11:=SMA(VAR10,3,1);  VAR12:=SMA(VAR11,3,1); 主力出现:DRAWICON(CROSS(VAR11,VAR12) AND (VAR11<40),L*0.98,1);  {黑马} A1A:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*1,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*1,5,1),COLOR330066;  A5A:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*1;  DRAWTEXT(CROSS(A1A,EMA(A1A,5))AND EMA(A1A,5)<A5A,L*0.98,'黑马'),COLORYELLOW;  {波段上行和买入}; 多:EMA(C,3),COLORYELLOW; 空:EMA(C,5),COLOR00FF00; 均衡:=EMA(空,5),COLORWHITE,;  VVARF1:=COUNT(CROSS(多,均衡),2)=1;  VVARF2:=COUNT(CROSS(空,均衡),2)=1;  ZAI:=FILTER(VVARF1 AND VVARF2,2);  DRAWTEXT(ZAI,均衡*0.985,' ▲'),COLORRED;  VV2:=REF(CLOSE,1);  VV3:=SMA((CLOSE-VV2),6,1)/SMA(ABS(CLOSE-VV2),6,1)*100;  DRAWICON(REF(VV3,1)>81 AND VV3<80,HIGH,2);  VF1:=MA(CLOSE,60)-MA(CLOSE,5)/3.2;  DRAWTEXT(IF(CLOSE<VF1 AND VOL/240>MA(VOL,5)/240 AND CLOSE>=REF(CLOSE,1)*1.08 AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW,'☆'),COLORRED;  VVARA:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;   VVARB:=EMA(0.667*REF(VVARA,1)+0.333*VVARA,5);  DRAWTEXT(IF(VOL>=1.3*MA(VOL,5) AND COUNT(VVARA>=VVARB AND VVARA<-17,3) AND REF(LOW,1)=LLV(LOW,120),1,0),LOW,'★注意买入'); VVARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;  DRAWICON(CROSS(82,VVARR1),HIGH,2);  DRAWTEXT(CROSS(82,VVARR1),HIGH,''),COLORYELLOW;  VVAR1:=(HIGH+LOW+OPEN+2*CLOSE)/5;  VVAR2:=REF(VVAR1,1);  VVAR3:=SMA(MAX(VVAR1-VVAR2,0),10,1)/SMA(ABS(VVAR1-VVAR2),10,1)*100;  HY3:=IF(COUNT(VVAR3<20,5)>=1 AND COUNT(VVAR1=LLV(VVAR1,10),10)>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0);  DRAWTEXT(HY3,LOW,' 注意买入'),COLORRED;

 

 

 



  声明:本站部分内容来自合作媒体及网络,不代表本站观点。本站不对上述言论承担责任。关键字:逃顶,买点,买入,均衡,卖点
相关阅读:
  • >>公式源码:VOL倍量柱()
    参数自己定吧,VOL,VOLSTICK;MA1:MA(VOL,M1);MA2:MA(VOL,M2);MA3:MA(VOL,M3);黄金柱: DRAWICON(LLV(L,3)>REF(L,3) AND HHV(V,3)<REF(V,3) AND REF(C,3)>REF(O,3) AND REF(V,3)>2*REF(V,4),V,1);{点击看本软件截图:分.析家公 式网 h...
  • >>指标源码:飞狐筹码主图附股东人数选股公式源码(主图)
    买好股公式文章飞狐筹码主图附股东人数选股公式源码,介绍筹码,主图,选股,公式,源码炒股技巧,让您在股市里买到好股票。说明:1.选股公式可以选出最近的f10信息中股东人数减少百分之二十的所有股票.(聚源资讯)2.筹码主图解释图上的三根线...
  • >>源码-大智慧把融大和金昌九整合为一个主图(主图)
    买好股公式文章大智慧把融大和金昌九整合为一个主图,介绍主图,源码炒股技巧,让您在股市里买到好股票。说明:用法请参考两位老师的说明,能不能给大家一点参考的意见,请各位同学自取所需。Wj:=' ';{ www,gongshi8,com 大智慧公式网}y...
  • 关键字: