大智慧公式网收录大智慧公式,大智慧公式源码.域名http://www.yaoyaoyuan.cn
所在的位置: 大智慧公式网 > 通达信公式 > 正文

源码-通达信单阳不破过均线必牛主图指标公式(主图)

2013-10-31 00:00:00 通达信公式教程
摘要: 历史跌:(CLOSE-HHV(HIGH,0))/HHV(HIGH,0)*100;{大智慧公式网选编}历史涨:(CLOSE-LLV(LOW,0))/LLV(LOW,0)*-1;年统计:(CLOSE-HHV(HIGH,240))/HHV(HIGH,240)*100; 声明:本站部分内容来自合作媒体及网络,不代表本站观点。本站不对上述言论承担责任。关键字:历史,选编,公式,统计庄股,抄底,买点,博弈,筹码通达信单阳不破过均线必牛主图指标公式主图 公式 指标 通达信 单阳N:=1;S:=1;阳涨幅:=4;阳倍量:=1.5;单阳:=C>O*(1+阳涨幅/100) AND VOL>REF(VOL,1)*阳倍量;DRAWTEXT(CURRBARSCOUNT<100 AND 单阳,L*0.98,阳),COLOR00FFFF;高不破价:=REF(C,BARSLAST(单阳));中不破价:=REF((C+L)/2,BARSLAST(单阳));低不破价:=REF(L,BARSLAST
N:=1;S:=1; 阳涨幅:=4; 阳倍量:=1.5; 单阳:=C>O*(1+阳涨幅/100) AND VOL>REF(VOL,1)*阳倍量; DRAWTEXT(CURRBARSCOUNT<100 AND 单阳,L*0.98,'阳'),COLOR00FFFF; 高不破价:=REF(C,BARSLAST(单阳)); 中不破价:=REF((C+L)/2,BARSLAST(单阳)); 低不破价:=REF(L,BARSLAST(单阳)); 单阳不破:=CURRBARSCOUNT<100 AND BARSLAST(单阳)<11 AND (LLV(L,BARSLAST(单阳))>低不破价 OR LLV(L,BARSLAST(单阳))=低不破价); STICKLINE(单阳不破,低不破价-低不破价*0.003,低不破价,4,0),COLORRED; DRAWTEXT(BARSLAST(单阳)=1 AND 单阳不破,低不破价*0.98,'1'),COLORGREEN; DRAWTEXT(BARSLAST(单阳)=2 AND 单阳不破,低不破价*0.98,'2'),COLORGREEN; DRAWTEXT(BARSLAST(单阳)=3 AND 单阳不破,低不破价*0.98,'3'),COLORGREEN; DRAWTEXT(BARSLAST(单阳)=4 AND 单阳不破,低不破价*0.98,'4'),COLORGREEN; DRAWTEXT(BARSLAST(单阳)=5 AND 单阳不破,低不破价*0.98,'5'),COLORGREEN; DRAWTEXT(BARSLAST(单阳)=6 AND 单阳不破,低不破价*0.98,'6'),COLORGREEN; DRAWTEXT(BARSLAST(单阳)=7 AND 单阳不破,低不破价*0.98,'7'),COLORGREEN; DRAWTEXT(BARSLAST(单阳)=8 AND 单阳不破,低不破价*0.98,'8'),COLORGREEN; DRAWTEXT(BARSLAST(单阳)=9 AND 单阳不破,低不破价*0.98,'9'),COLORGREEN; DRAWTEXT(BARSLAST(单阳)=10 AND 单阳不破,低不破价*0.98,'10'),COLORGREEN; 两天:=LLV(L,BARSLAST(单阳))>低不破价 OR LLV(L,BARSLAST(单阳))=低不破价; 一般:=LLV(L,BARSLAST(单阳)-2)>低不破价 OR LLV(L,BARSLAST(单阳)-2)=低不破价; 一般选股:STICKLINE(CURRBARSCOUNT<100 AND BARSLAST(单阳)<9 AND 两天 AND 一般,低不破价,低不破价,2,0),COLORWHITE; 较强:=LLV(L,BARSLAST(单阳)-2)>中不破价 OR LLV(L,BARSLAST(单阳)-2)=中不破价; 较强选股:STICKLINE(CURRBARSCOUNT<100 AND BARSLAST(单阳)<9 AND 两天 AND 较强,中不破价,中不破价,2,0),COLORMAGENTA; 最强:=LLV(L,BARSLAST(单阳)-3)>高不破价 OR LLV(L,BARSLAST(单阳)-2)=高不破价; 最强选股:STICKLINE(CURRBARSCOUNT<100 AND BARSLAST(单阳)<9 AND 两天 AND 最强,高不破价,高不破价,4,0),COLORYELLOW; 现价:DRAWLINE(CURRBARSCOUNT=TOTALBARSCOUNT,CONST(C),CURRBARSCOUNT=1,C,3)DOTLINE; VARR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN)); 买盘:=IF(CLOSE>OPEN,VARR1*(HIGH-LOW),IF(CLOSE<OPEN,VARR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)); 成交量比:=买盘/VOL*100; 主力持仓:=EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3); 主力筹码集中度:=WINNER(C)*100; 散筹筹码集中度:=(WINNER(C*1.1)-WINNER(C*0.9))*100; 量筹买点:=主力筹码集中度>主力持仓 AND 主力持仓>散筹筹码集中度 AND 成交量比>89.9 AND FINANCE(7)<2500000000 AND DYNAINFO(7)>0; DRAWTEXT(量筹买点,REF(CLOSE,1),'量筹'),COLOR000055; STICKLINE(量筹买点,CLOSE,O,2.8,0),COLOR000055; STICKLINE(量筹买点,CLOSE,O,2,0),COLOR000088; STICKLINE(量筹买点,CLOSE,O,1.5,0),COLOR0000AA; STICKLINE(量筹买点,CLOSE,O,1,0),COLOR0000CC; STICKLINE(量筹买点,CLOSE,O,0.5,0),COLOR0000EE; D7:="MACD.DIF#WEEK"-"MACD.DEA#WEEK"; D8:="MACD.DIF#MONTH"-"MACD.DEA#MONTH"; 黑码抄底:=CROSS("KDJ.J#WEEK"(9,3,3),0) AND D8>0 OR CROSS("KDJ.J#MONTH"(9,3,3),0) AND D7>0; STICKLINE(黑码抄底,CLOSE,OPEN,3,0),COLORYELLOW;{KDJ和MACD的周月之间的配合} DRAWTEXT(黑码抄底,LOW-0.03,'黑码'),COLORMAGENTA; STICKLINE(黑码抄底,CLOSE,OPEN,3.2,0),COLOR000099; STICKLINE(黑码抄底,CLOSE,OPEN,2.6,0),COLOR0000AA; STICKLINE(黑码抄底,CLOSE,OPEN,2.2,0),COLOR0000CC; STICKLINE(黑码抄底,CLOSE,OPEN,1.8,0),COLOR0000DD; STICKLINE(黑码抄底,CLOSE,OPEN,1.3,0),COLOR0000FF; STICKLINE(黑码抄底,CLOSE,OPEN,0.5,0),COLORCC66FF; FH11:=REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3)<REF(MACD,4); FH21:=MACD>=0 AND COUNT(MACD>REF(MACD,1),1)=1; FH3:=EMA(C,30)>=REF(EMA(C,30),1) AND COUNT(EMA(C,5)>EMA(C,10) AND EMA(C,10)>EMA(C,30),1)=1; FH4:=CROSS(C,EMA(C,30)) OR C>EMA(C,30); FH5:=FH11 AND FH21 AND FH3 AND FH4; FH6:=FH11 AND FH21 AND FH3 AND FH4 AND ABS((MACD.DIF-MACD.DEA)/C)<0.018; FH7:=FH11 AND FH21 AND FH3 AND FH4 AND MACD<0.10; 腾:=FH5 OR FH6 OR FH7; DRAWTEXT(腾,(LOW * 0.985),'腾'),COLOR00FFFF; STICKLINE(腾,CLOSE,O,2.8,0),COLOR00FFFF; STICKLINE(腾,CLOSE,O,2,0),COLOR0077FF; STICKLINE(腾,CLOSE,O,1.5,0),COLOR0099FF; STICKLINE(腾,CLOSE,O,1,0),COLOR00AAFF; STICKLINE(腾,CLOSE,O,0.5,0),COLOR00CCFF; M月:=CROSS("MACD.DIF#MONTH","MACD.DEA#MONTH");DRAWTEXT(M月,LOW-0.04,'M月'),COLORMAGENTA; K月:DRAWTEXT(CROSS("KDJ.K#MONTH"(9,3,3),"KDJ.D#MONTH"(9,3,3)) ,LOW-0.05,'K月'),COLORMAGENTA; K周:DRAWTEXT(CROSS("KD.K#WEEK"(9,3,3),"KD.D#WEEK"(9,3,3)) ,LOW-0.08,'K周'),COLORRED; M周:=CROSS("MACD.DIF#WEEK","MACD.DEA#WEEK");DRAWTEXT(M周,LOW-0.1,'M周'),COLORRED; 月叉:DRAWTEXT(CROSS("KDJ.D#MONTH"(9,3,3),"KDJ.K#MONTH"(9,3,3)) ,H+0.05,'K20'),COLORGREEN; 周叉:DRAWTEXT(CROSS("KDJ.D#WEEK"(9,3,3),"KDJ.K#WEEK"(9,3,3)) ,H+0.08,'K5'),COLORGREEN; M5:=CROSS("MACD.DEA#WEEK","MACD.DIF#WEEK"); DRAWTEXT(M5,H+0.10,'M5'),COLORGREEN; M20:=CROSS("MACD.DEA#MONTH","MACD.DIF#MONTH"); DRAWTEXT(M20,(H+0.15),'M20'),COLORGREEN; STICKLINE(月叉 OR 周叉 OR M5 OR M20,HIGH,LOW,0.2,0),COLORGREEN; STICKLINE(月叉 OR 周叉 OR M5 OR M20,OPEN,CLOSE,0.2, 0),COLORGREEN; STICKLINE(M月 OR K月 OR K周 OR M周,OPEN,CLOSE,2.8,0),COLOR808080; STICKLINE(M月 OR K月 OR K周 OR M周,OPEN,CLOSE,2.5,0),COLOR919890; STICKLINE(M月 OR K月 OR K周 OR M周,OPEN,CLOSE,2.2,0),COLORB4B5AF; STICKLINE(M月 OR K月 OR K周 OR M周,OPEN,CLOSE,1.7,0),COLORCCCCCC; STICKLINE(M月 OR K月 OR K周 OR M周,OPEN,CLOSE,1.2,0),COLORDDDDDD; STICKLINE(M月 OR K月 OR K周 OR M周,OPEN,CLOSE,0.8,0),COLOREEEEEE; STICKLINE(M月 OR K月 OR K周 OR M周,OPEN,CLOSE,0.4,0),COLORF5F1F1; STICKLINE(M月 OR K月 OR K周 OR M周,OPEN,CLOSE,0.1,0),COLORFFFAFA; T0:=BARSCOUNT(CLOSE)>12; T1:=CLOSE=LLV(CLOSE,12); T2:=RSI.RSI1>LLV(RSI,12); T3:=RSI.RSI1<21; TRSI:=T0 AND T1 AND T2 AND T3 AND CLOSE/HHV(CLOSE,120)<0.7; RSI成W底:=IF(REF(TRSI,1) AND CLOSE>REF(CLOSE,1),1,0); DRAWTEXT(RSI成W底,(L*0.98),'W'),COLORLIMAGENTA;{RSI在低位上穿且收盘价是12来最低} STICKLINE(RSI成W底,OPEN,CLOSE,2,0),COLORLIMAGENTA; WR:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14)); WR反向:=(0-WR)-100,COLORYELLOW; RSI买点:=RSI.RSI1<20 AND RSI.RSI1>REF(RSI.RSI1,1); WR反向买点:=WR反向>-80 AND WR反向<REF(WR反向,1); 梁队长选股:=RSI买点 AND WR反向买点; DRAWTEXT(梁队长选股,LOW-0.03,'梁')COLORRED;{WR和RSI的双重买点} STICKLINE(梁队长选股,OPEN,CLOSE,3,0)COLORRED; STICKLINE(梁队长选股,HIGH,LOW,0,1),COLORYELLOW,LINETHICK2; STICKLINE(梁队长选股,OPEN,CLOSE,2.5,0),COLOR0033FF; STICKLINE(梁队长选股,OPEN,CLOSE,2.1,0),COLOR00BEFF; STICKLINE(梁队长选股,OPEN,CLOSE,1.7,0),COLOR13BCFF; STICKLINE(梁队长选股,OPEN,CLOSE,1.3,0),COLOR13D1FF; STICKLINE(梁队长选股,OPEN,CLOSE,0.9,0),COLOR00D6FF; STICKLINE(梁队长选股,OPEN,CLOSE,0.4,0),COLOR13E5FF; STICKLINE(梁队长选股,OPEN,CLOSE,0,0),COLOR00F6FC; LC:=REF(CLOSE,1); AG:=REF(RSI.RSI1<45,1) AND RSI.RSI1>45; TYP:=(HIGH+LOW+CLOSE)/3; CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)); B:=REF(CCI<-100,1) AND CCI>=-100; MMS:=MA(3*RSI.RSI2-2*SMA(MAX(CLOSE-LC,0),16,1)/SMA(ABS(CLOSE-LC),16,1)*100,3); W:=REF(MMS<39,1) AND MMS>=39; RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100; K:=SMA(RSV,3,1); D:=SMA(K,3,1); JG:=3*K-2*D; F:=REF(JG<10,1) AND JG>=10; 牛股:=AG AND B AND W AND F; STICKLINE(牛股,OPEN,CLOSE,2.5,0),COLORMAGENTA;{3个指标会和而成其中RSI强势KDJ低位} DRAWTEXT(牛股,(L-0.08),'牛股'),COLORMAGENTA; BIAS0:= (C-MA(C,2))/MA(C,2)*100; D1:=INDEXC; D2:=MA(D1,13); DR2:=D2>1.050*D1; E2:=(C-REF(C,26))/REF(C,26)*10; SJ1:=DR2; SJ2:=E2<-2.30; SJ3:=BIAS0<-2.7; SJ5:=SJ1 AND SJ2 AND SJ3; SJ6:=CROSS(0.5,SJ5); JS1:=CROSS(SJ6,0.5); JS2:=BARSLAST(JS1=1); JS3:=JS2<=5 AND C<REF(C,JS2); 赛:=SJ6 OR JS3; DRAWTEXT(赛,(L*0.97),'赛'),COLORRED;{大赛排名第一} STICKLINE(赛,OPEN,CLOSE,1,0)COLORRED; AA05:=MA(C,5); 五日乖离率:=(C-AA05)/AA05*100; AA30:=MA(C,30); 三拾日乖离率:=(C-AA30)/AA30*100; MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30; 买入:=FILTER(MR,10); BIAS1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100; BIAS2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100; BIAS3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100; BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6; 乖离:=MA(BIAS,3); 接近底部:=(乖离<-12 AND 乖离>=-18); 乖离抄底:=IF(乖离<-18,1,0); 乖离信号:=乖离抄底 OR 买入; DRAWTEXT(乖离信号,(L*0.93),'乖'),COLOR7FFF00; VAR41:=CLOSE/MA(CLOSE,30)*100<75; VAR42:=CLOSE/MA(CLOSE,50)*100<78; VAR43:=HIGH>LOW*1.053; VAR44:=VAR43 AND COUNT(VAR43,5)>2; VAR45:=VAR44 AND (VAR41 OR VAR42); VAR46:=DMA(EMA(CLOSE,5),SUM(VOL,8)/2.8/CAPITAL); VAR47:=(CLOSE-VAR46)/VAR46*100; 赢:=REF(VAR47,1)<-34 AND VAR47>REF(VAR47,1) AND REF(VAR47,1)<REF(VAR47,2) AND VAR47-REF(VAR47,1)>1.76 OR VAR45; DRAWTEXT(赢,(L*0.88),'赢'),COLORMAGENTA; 获利:=WINNER(CLOSE)*100; 获利盘:=WINNER(C)*100; 近邻筹码:=(WINNER(C*1.07)-WINNER(C*0.93))*85; 获利纵横:=获利盘-近邻筹码,NODRAW; 换手率:=V/CAPITAL*100; AGA:=IF(DYNAINFO(8)>0.01,0.01*DYNAINFO(10)/DYNAINFO(8),DYNAINFO(3)); AGB:=(DYNAINFO(5)<0.01 || DYNAINFO(6)<0.01); AGC:=IF(AGB,1,(AGA<(DYNAINFO(5)+0.01) && AGA>(DYNAINFO(6)-0.01))); MA21:=IF(AGC,0.01*EXPMA(AMOUNT,21)/EXPMA(VOL,21),EMA((HIGH+LOW+CLOSE)/3,21)); MA60:=IF(AGC,0.01*EXPMA(AMOUNT,60)/EXPMA(VOL,60),EMA((HIGH+LOW+CLOSE)/3,60)); MA∞:=IF(AGC,DMA(AMOUNT/(100*VOL),100*VOL/FINANCE(7)),EMA((HIGH+LOW+CLOSE)/3,120)); 收盘价:=CLOSE; TJ1:=获利>40; TJ2:=MA60>MA∞ AND MA21>MA60; TJ3:=收盘价<MA∞; 受伤庄股:=TJ1 AND TJ2 AND TJ3 STICK; DRAWTEXT(受伤庄股,(L*0.99),'伤'),COLORCYAN; 跟进:=COUNT(获利纵横>REF(获利纵横,1),5)=5 AND 获利盘>REF(获利盘,1)STICK; DRAWTEXT(跟进,(L*0.995),'横'),COLORRED; 锁仓:=获利盘>=85 AND 近邻筹码<30 AND 换手率<5 STICK; DRAWTEXT(锁仓,(L*0.99),'锁'),COLORWHITE; 强庄:=CROSS(获利盘,近邻筹码)AND 获利盘>50 AND 获利纵横>30 STICK COLORRED; DRAWTEXT(强庄,(L*0.97),'强'),COLORRED; 启动:=REF(获利盘,1)<50 AND 获利盘>60 AND 近邻筹码<REF(近邻筹码,1)STICK; DRAWTEXT(启动,LOW-0.03,'启'),COLOR5555FF; STICKLINE(启动,CLOSE,O,2.8,0),COLOR4444FF; STICKLINE(启动,CLOSE,O,2,0),COLOR5555FF; STICKLINE(启动,CLOSE,O,1.5,0),COLOR7777FF; STICKLINE(启动,CLOSE,O,1,0),COLOR9999FF; 博弈K线长:=100*(WINNER(CLOSE)-WINNER(OPEN)); 博弈K线收盘差:=博弈K线长>=20; 大单动向:(LARGEINTRDVOL-LARGEOUTTRDVOL)*10000/FINANCE(7),NODRAW; HSL:=100*VOL/(FINANCE(7)/100); 换手:=MA(HSL,1)<3; 博弈长阳:=博弈K线收盘差 AND 换手 COLORMAGENTA; DRAWTEXT(博弈长阳,LOW-0.03,'博弈'),COLORMAGENTA; STICKLINE(博弈长阳,CLOSE,O,2.8,0),COLOR770077; STICKLINE(博弈长阳,CLOSE,O,2,0),COLOR990099; STICKLINE(博弈长阳,CLOSE,O,1.5,0),COLORBB00BB; STICKLINE(博弈长阳,CLOSE,O,1,0),COLORDD00DD; STICKLINE(博弈长阳,CLOSE,O,0.5,0),COLORFF00FF; 三日:=SUM(大单动向,3); 五日:=SUM(大单动向,5); 十日:=SUM(大单动向,10); 二十日:=SUM(大单动向,20); 三十日:=SUM(大单动向,30); 六十日:=SUM(大单动向,60); 涨:=大单动向>0 AND 三日>0 AND 五日>0 AND 十日>0 AND 二十日>0 AND 三十日>0 AND 六十日>0; DRAWTEXT(涨,(LOW * 0.99),'资'),COLORRED; K1:=REF(C,1)=DYNAINFO(3) AND O=DYNAINFO(4) AND C=DYNAINFO(7) AND H=DYNAINFO(5) AND L=DYNAINFO(6); K2:=BARSLAST(V=HHV(V,20)); K3:=BACKSET(K1,K2+1); STICKLINE(K2=0 AND K3=1,H,H*1.003,8*N,0),COLORYELLOW; 收:C,NODRAW; DRAWTEXT(S=1&&K2=0&&K3=1,H*1.02,'20天内的最高量'),COLORYELLOW; 过均必牛:SUM(CLOSE*VOL,FROMOPEN)/SUM(VOL,FROMOPEN),COLORYELLOW,DOTLINE;



  声明:本站部分内容来自合作媒体及网络,不代表本站观点。本站不对上述言论承担责任。关键字:庄股,抄底,买点,博弈,筹码
相关阅读:
  • >>指标源码:大智慧地量选股公式源码(公式)
    买好股公式文章大智慧地量选股公式源码,介绍选股公式,大智慧,地量炒股技巧,让您在股市里买到好股票。大智慧的{N 30 1 100}地量:ref(v,1)=ref(llv(v,n),1);同花顺的://参数N(1,100,30)地量:REF(V,1)=REF(LLV(V,n),1); 声明:本站部分内...
  • >>公式源码-通达信叠加主图的股指期货交割日指标公式(主图)
    买好股公式文章通达信叠加主图的股指期货交割日指标公式,介绍股指,期货炒股技巧,让您在股市里买到好股票。让你观察股指期货对市场的影响{www、gongshi8、com 大智慧公式网}{股指期货交割日}MNM:=IF(PERIOD=5,1, {日}DRAWNULL);交割...
  • >>公式源码:通达信成交量选股公式源码(成交量)
    买好股公式文章通达信成交量选股公式源码,介绍选股,成交量炒股技巧,让您在股市里买到好股票。W:=HHV(V,10)>REF(HHV(V,10),2);{www。zhibiao8。com 指标公式}XG:W; 声明:本站部分内容来自合作媒体及网络,不代表本站观点。本站不对上述言...
  • 关键字: